Virtualization gives us cascading problems!

Today I was finally biting the bullet and was going to install a Windows 8 VM and force myself to start learning a little about it.  I think it is no secret that many people are not a fan of Windows 8 and I know my first reaction was “omg wheres the start button and how do I get a command prompt!?”.  Next thing I know I am pinning all of these to the taskbar so I don’t have to hunt for them again…sad.

Anyhow, I mounted a Windows 8 ISO fresh from my Microsoft Technet Subscription (quite worth it, imo!).  The machine booted, installed, etc, appeared to be no problems.  After it installed, it rebooted and did nothing but spin.  WTF?  Thinking it was just a fluke, I created another VM with all default options, clicked through everything.  After it installed and rebooted, guess what, it also just spun.

Off we go to google and we find this:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2006859

Oh, requires ESXi 5.0 U1 or never.  I’m running vanilla 5.0.  Whoops.  No problem, I go download the 5.1 U1 (newest as of this writing) ISO, burn it, and proceed to boot it on 1 of my hosts.  3 options we have, 1) Upgrade & Preserve VMFS datastore 2) Install & Preserve VMFS datastore 3) Install & do not Preserve.

I tried to do the upgrade.  It spun for a little while and then came back complaining about one of my .VIBs, a Cisco VEM vib that it said is conflicting and the install/upgrade bailed.  It said to either use ISO builder or to remove the VIB.  Since any good administrator doesn’t store any VMs locally, I decided to try again with option 3, knowing it’d blow up my network configuration and I’d need to repair it when I was done, no big deal.

The install went fine, host rebooted and 5.1 U1 running.  Now I try to add it back to vCenter.  Now I’m getting the message about the vpxa agent timing out.  I can connect to the host just fine directly, but it doesn’t want to add back to vCenter.  Connecting directly to the 5.1 ESXi meant downloading a new 5.1 vSphere client. (I know I know, I should be using the WebUI).

Some quick research indicated you can not add a 5.1 host to a 5.0 vCenter server.  Ok great, so lets go upgrade that as well.  Here is the CD launch screen, its slightly more daunting that the 5.0 one:

2013_5_9_vcenter_pic

 

So here we go with a required upgrade of the vCenter database (which invalidates it with older vCenters), new database server (MSSQL2008R2 bundled).  Sure hope nothing breaks in the meanwhile….

All of this just because I got some crazy idea about wanting to run a Windows 8 VM…. /wrist

Tagged , , , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.